iExplorer Support

What are the system requirements?

Last Updated: Jun 16, 2017 04:36PM CDT
iExplorer works with all iPhones, iPads, and iPods ever made. iDevice compatibility all depends on your iOS version, computer OS, and which major version of iExplorer you are using. You can download the iExplorer version you need from our Downloads page

​You'll also need a version of iTunes that supports your iOS version and a Lightning or 30 pin USB cable to plug in your iPhone, iPad, or iPod to your Mac or Windows PC. 

iExplorer 4
Supports all iOS versions including iOS 10 (and all regular iPods).
MacOS: 10.9* - 10.12  (Mavericks, Yosemite, El Capitan, and Sierra)

PC: Windows 7, Windows 8, and Windows 10

iExplorer 3

Supports iOS 1-9 (and all regular iPods). 
MacOS: 10.6** - 10.11 (Snow Leopard - El Capitan)
PC: Windows XP, Vista, 7, 8, and 10 

* iExplorer 4.1 or later requires Mac OS 10.10 or later, but iExplorer 4.0.x works with 10.9 or later. 
** Macs running 10.6 Snow Leopard must install iExplorer 3.8.6.1 due to Apple depreciating 10.6 in iOS 9 and 10 and due to its lack of support for more modern and robust MacOS development frameworks and tools. You can download a 10.6.8 compatible version of iExplorer 3 from HERE, but you should also note that Apple's minimum system requirement for using an iOS 10 device with iTunes on a computer is Mac OS 10.9.5 or later and Windows 7 or later which is the exact same as iExplorer 4's requirements. For iOS 9, Apple's minimum system requirement for an iTunes compatible version is Mac OS 10.7 or later and Windows XP or later. 

support@macroplant.com
http://assets1.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete