iExplorer Support

I can't open iExplorer on my 10.6 Mac

Last Updated: Sep 19, 2014 12:04PM CDT
If your Mac is running 10.6 Snow Leopard, and you receive the message: "You can't open the application iExplorer.app because it is not supported on this type of Mac", you must be using a Mac with a 32 bit processor, and the most recent versions of iExplorer for Mac are now 64 bit only.

You can still use iExplorer with your 32 bit Mac, but you'll need to use our 32 bit compatible version which can still do everything the 64 bit version does. You can download it from the link below:


http://www.macroplant.com/release/iExplorer-3.3.1.0.dmg

Only Macs made in 2006 or earlier would have a 32 bit processor. 

Just be sure to not update iExplorer in order to keep 32 bit compatibility. You can choose "Skip this Version" in any software update windows, and iExplorer preferences even has a checkbox to stop checking for updates on the General tab. 

support@macroplant.com
http://assets2.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete