iExplorer Support

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

IPhone XS doesn't show up in IExplorer

Josh Nov 01, 2018 02:01PM CDT

I am trying to get this product integrated into some software and the IPhone XS doesn't show up in IExplorer while an IPhone 8 does show up. This is in spite of working through the suggestions when an IPhone doesn't appear in IExplorer. This is on version 4.2.5

Up 0 rated Down
Mike Nov 01, 2018 02:14PM CDT Macroplant Agent

Please first check the new USB Accessory setting on your iPhone XS and make sure it’s turned to ON. Here’s how:

  1. Tap Settings > Touch ID & Passcode (or Face ID & Passcode)
  2. Enter your iOS passcode
  3. Scroll down to USB Accessories and if it’s OFF, tap the switch to ON (green).
  4. Check iExplorer again after unplugging and reconnecting the USB cable.

If that doesn’t allow your iPhone to connect, please try tapping Settings > General > Reset > Reset Location & Privacy. Then, enter your iOS passcode to proceed, and once reset, try checking in iTunes and iExplorer again (after unplugging and replugging the USB cable or closing and reopening iExplorer).

Up 0 rated Down
Mike Nov 01, 2018 05:38PM CDT Macroplant Agent

The storage size won’t matter since it’s all still the same iOS. iExplorer definitely supports all iPhones and hard drives.

These steps should resolve it for you….Open iTunes, select your iPhone XS to bring up its Summary tab, and if your iPhone is set to backup to iCloud, change the backup location to This Computer and check the box to Encrypt iPhone Backup below it and choose a password you can remember which will create a new iTunes backup on your computer, and then once that backup is finished, completely quit and reopen iExplorer and see if your iPhone now appears in iExplorer along with the new backup you just made.

Post Your Public Answer


support@macroplant.com
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete